使用しているrubyの標準添付ライブラリが、どのバージョンを使っているか知りたい場合は、 ライブラリをrequireしてモジュール名::VERSIONで取得する事が出来る。

irb(main):001:0> require csv
=> true
irb(main):002:0> p CSV::VERSION
"2.4.8"
=> "2.4.8"

上記の例はirbからだが、プログラム上でも取得出来るのでバージョンによって処理を分けたいとかいうときに使えるかも。